This site is in read only mode. Please continue to browse, but replying, likes, and other actions are disabled for now.
1 / 40
Dec 2019

What do I do?
Almost everything is lost!

I thought I was in /run/media/somewhere.

It stopped at /dev/, but lots of stuff at /home is gone too. ;_;.
At least the cloud files are still there, but lots of directories are gone.
/bin is gone.


What I was trying to accomplish

My goal was to have stepmania working on a smaller computer than a mini-ITX,
because of constant wi-fi issues and why not go smaller?
My OS of choice: manjaro, but I was also going to try out raspbian and see how that fares
Also, I really preferred an external SSD card
as I've had bad experiences with the longetivity of SD cards lasting only a year.

Because RPi4 cannot yet boot from external storage,
one needs to install an OS on both the SD card as well as the external storage
and then copy some files to /boot on the SD card.

What happened instead

I was installing a new manjaro OS using manjaro-arm-installer,
multiple times because I wanted to test it on a flash-drive first and see if it worked.
Also, I was installing raspbian too to see if that worked better/worse.
After testing on flash-drives I bought an external SSD card.
I mounted it, but for some reason demounted it again and used manjaro-arm-installer.
This time I overlooked the fact that I was creating the OS to my own harddisk until it was too late.
Having noticed I had just tried installing ARM on my non-ARM computer, I searched for the changes made in /boot and got really confused.
Things looked normal. All the old files were still there.
"Perhaps I did install it on my external harddisk after all?" I thought
I also noticed that the external harddisk was remounted on thunar.
I already had installed raspbian on the SSD card before,
so perhaps I should clean it first this time around.
Besides, I don't know anymore if raspbian or an unfinished manjaro is installed on it anymore.
So when I went there, noticed that there were ARM files in ./boot,
I then decided to open terminal and delete all the files on it's root folder too so I would have a clean empty external harddrive again.

But ales..
I was NOT in the root folder of my external harddisk.
I was in the root folder of my internal harddisk.

And by the time I realized it, /sbin, /bin were already gone and my encrypted partition corrupted.


It's probably better to buy a tinkerboard S and use eMMC or just use what I already have, an Asrock J4205 board.
Also, should have made backups.
I would have gone back just to be on the safe side the moment I noticed I accidentally was installing manjaro-ARM architecture on my manjaro-amd64 computer.


  • created

    Dec '19
  • last reply

    Feb '20
  • 39


  • 926


  • 26


Reinstall - and never do it again.

I didn't mean to.
I was trying to reinstall manjaro arm on a SD card, but chose my SSD instead, then I noticed on gparted that my BOOT partition was turned into the ARM version, but the boot files were still on /boot?
So I tried deleting the BOOT partition, those BOOT files was actually root '/'.

I did try it in October and did not go thru, it was saying this command is not safe, did not proceed.

More than likely, whatever you have left. . . still isn't worth fixing. Maybe there's a couple of files you can save. Otherwise, reinstall, and enjoy a fresh Manjaro. Timeshift backup?

Yes, I understand I need a fresh reinstall.
I just hope I can save those files.
I don't want to lose them.
They are very important to me.
I encrypted my partition, would that make matters worse?

It's probably too late. You'll need to get them from your backup. If you don't have one, I revert back to, it's probably too late. You can save what is left, but anything that was deleted, is definitely deleted.

I have no idea, I've never encrypted anything before. But if there's nothing left, there's no need for encryption, so I'd say you're probably in the same boat.

I once did an "rm -rf /" to demonstrate a friend that it's safe to run it without root permissions but then it started to try deleting all the files and folders reporting that it is missing permissions for each. Luckily I was quick enough to abort before it reached /home, otherwise my system would be still intact but I'd have lost all my user data. :smiley:

That could be made a viral challenge!

Well, well, well...another delayed convert to the Church of Backups.

You thought?? Your terminal prompt didn't show you the current working directory?

Unfortunately, without working backups, you're going to pay the price for your lack of awareness.

Uhm.. I'm sorry you lost your files @folaht, but I wouldn't give up without a fight; as far as I know, rm doesn't delete any data, just the reference to the files, and tools to recover files does exist on Ext4. Encryption will make things harder, however, and I have been lucky enough not to have any experience with this - but I know one thing: Stop writing to the disk. What's there is there until it's overwritten.
Here's a couple of links: 2

Good luck!

I have used R-Linux and tested it on lost or deleted files with great luck. However, I never tried it on a Encryption system.

use testdisk, grab the contents of your /home directory and reinstall manjaro. as others mentioned if you have not overwritten them the data is still there, the sooner you do this the better especially with an ssd because of the way is stores data

Yes, modern systems will stop you unless you explicitly use the --no-preserve-root flag
(I thought you still needed f or force too..)
... so ... I wonder why not in this case ...

Yes testdisk save two times my life :wink: but now
as always :expressionless:


backup is better the testdisk :slight_smile:

Amen to that!


Similar to the Tide Pod Challenge (in terms of destructive consequences)? :grin: